libQGLViewer and Bulbcalculator

A couple of weeks ago, I finally made a merge request to the libQGLViewer maintainer for the code to port the library from the the old QGLWidget to the new QOpenGLWidget.

libQGLviewer is the library that Bulbcalculator uses for the 3D rendering of the project. The problem with the old version was that, for some reason, the widget was broken from a certain version of Qt (it seems from the release 5.5.x) so no 3D view is shown and, worse, the other QMdiSubwindow are unresponsive.

So if you use libQGLViewer, switch to the newer 2.7.0 version that should build against the new Qt library (at least from the 5.4.x version)